yaml-v2

Use a requirements file from a submodule, this shouldn’t give an error.

YAML file used to build this docs,

 1
 2
 3
 4
 5
 6
 7
 8
 9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
version: 2

build:
  image: latest

formats:
  - epub
  - pdf

sphinx:

  # At this moment, the builder has to match to the DB setting from
  # "Advanced settings" because otherwise we will receive a build
  # error. This behavior could probably change in the future to take
  # precedence by the YAML config. More context on this at
  # https://github.com/rtfd/readthedocs.org/issues/4638
  builder: html

  configuration: docs/conf.py
  fail_on_warning: false

python:
  version: 3.6
  system_packages: true
  install:
    - requirements: requirements.txt
    - requirements: blog/requirements.txt

submodules:
  include: all
  recursive: true

>>> # Build at
>>> import datetime
>>> datetime.datetime.utcnow()  # UTC
datetime.datetime(2019, 6, 11, 22, 53, 43, 422301)